Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Issue with deleted fields

Issue with deleted fields 2 weeks 1 day ago #19589

  • Carl
  • Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
One of our users has reported a problem with a package.

They set up an import script to take data from a source table and load into another table. This worked fine when they set it up. This script was also in a package and the package also worked correctly.

Subsequently one of the columns from the source table has been removed (presumably by their IT department). I
f the import script is run manually it pops up an error message warning that the source field hasn’t been found, but if the package runs it completes without error and just appears to leave that field blank. None of the error settings appear to have any effect in making it report the problem.

I’ve replicated the issue on my local machine by using very basic source and destination tables, setting up col2, col2 and col3 in a source table and then removing col3 afterwards. The Import script when run complains:

But the package log doesn’t report anything and neither does the import log.
Is there any way of getting the package to warn users that one (or more) of the source fields in an import is missing?

Thanks,
Carl

Please Log in or Create an account to join the conversation.

Issue with deleted fields 2 weeks 1 day ago #19590

  • admin
  • admin's Avatar
  • Offline
  • Moderator
  • Moderator
  • Deeds not Words
  • Posts: 7687
  • Karma: 33
  • Thank you received: 437
Hi Carl

Thank you for your feedback

We have added checks for data structure changes to the latest release

9.2.6.0

+ Added: Support for Telegram Bot API
+ Added: Checks for source and target structure changes
Mike

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

We have 235 guests and 2 members online