Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Errors with 'Use Bulk API' for Salesforce connection

Errors with 'Use Bulk API' for Salesforce connection 1 year 2 months ago #18115

  • cstaley
  • Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 37
  • Karma: 2
  • Thank you received: 2
I'm running Visual Importer Enterprise 9.2.2.4. You recently made changes so the utilization of the Bulk API was more efficient when importing data with a large number of records. I have a couple issues I'm seeing. The error messages don't tell me much. I'm hoping to get additional clarification regarding what they mean and what I may need to change.

Error 1 - Error encountered during CloseBatch: HTTP/1.1 400 Bad Request
I get this error when my target destination option for Salesforce is configured to 'Use Bulk API' AND my Transformation is set to 'Add New and Update Old Records'.

Error 2 - Error encountered during AddBatch: Socket Error # 10054
I get this error when sending large amounts of data to Salesforce. My target destination option for Salesforce is configured to 'Use Bulk API' AND my Transformation is set to 'Add New Records'.

I'm not sure how to deal with each error. The first I can get around by removing the Use Bulk API checkbox. The other seems to recover on it's own.

I attempted to attach two VI.log files. The largest of the two is 45KB. The system say's they exceed the allowed limit. I'm not sure if they will get stripped.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

We have 149 guests and no members online