GetScript returning incorrect data type.

  • Posts: 327
  • Thank you received: 1

GetScript returning incorrect data type. was created by SelwynO

On performing "GetScript" that returns a STRING, VimpX is passing a NULL in the first character. VimpX interface is expecting a "L".

This is similar to the problem reported in a earlier post regarding the error message. I believe you resolved it by changing the data returned to a Variant.

Regards
Selwyn
7 years 1 month ago #11507

Please Log in or Create an account to join the conversation.

  • Posts: 1194
  • Karma: 3
  • Thank you received: 149

Replied by Peter.Jonson on topic GetScript returning incorrect data type.

This was correct in the latest release
Peter Jonson
ETL Developer
7 years 1 month ago #11521

Please Log in or Create an account to join the conversation.

  • Posts: 327
  • Thank you received: 1

Replied by SelwynO on topic GetScript returning incorrect data type.

The version installed is 5.2.0.21 and is the same as the licensed version I downloaded this morning. It is the version that I received the error on.

This problem, to the best of my knowledge, has not been previously reported.

See the screen dumps of the data-:

ASCII screen dump.




Hex screen dump.






There is another issue with the GetScript.

The data passed exceed the maximum allowed by our ActiveX handler. There is a lot of default values, particularly in the mapping that consumes significant space. I do have an option to increase the buffer size. I tested it with 10k buffer, but the data received was still 4098. This could be a bug in my ActiveX component, of which I have no control over, or an ActiveX limitation, or a problem on your side.

Selwyn
7 years 1 month ago #11532
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 8321
  • Karma: 33
  • Thank you received: 545

Replied by admin on topic GetScript returning incorrect data type.

We have changed it to variant as you wanted. There is nothing else we can do i am afraid.

Mike
Mike
ETL Architect
7 years 1 month ago #11533

Please Log in or Create an account to join the conversation.

  • Posts: 327
  • Thank you received: 1

Replied by SelwynO on topic GetScript returning incorrect data type.

The change you made was for the error message. That worked and that issue is now closed.

This is another matter and is for the GetScript method.

This has never been reported and is a new and entirely different issue, though I expect requires a similar fix.

Selwyn
7 years 1 month ago #11534

Please Log in or Create an account to join the conversation.

  • Posts: 8321
  • Karma: 33
  • Thank you received: 545

Replied by admin on topic GetScript returning incorrect data type.

An email with new version was send to you yesterday

Peter
Mike
ETL Architect
7 years 1 month ago #11536

Please Log in or Create an account to join the conversation.

 

This site uses cookies. By continuing to browse the site, you are agreeing to our use of cookies