Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Large Transformation - All Settings Lost?

Large Transformation - All Settings Lost? 11 months 3 weeks ago #18731

Hello,
I worked on a large transformation for about 3 weeks. Got it running, and I went in to run it manually today to check something and literally nothing is there. Like it lost everything, reader settings, validator settings, transformation settings and writer settings.

I saved it every time I went into or out of each part and it has been running fine. Just found a problem and opened it up. Tried to run a manual process with the problem file and it is unaware of any of the fields etc.

I am really frustrated and concerned. Can anyone assist me with this please?

Thank you.

Please Log in or Create an account to join the conversation.

Large Transformation - All Settings Lost? 11 months 3 weeks ago #18732

  • admin
  • admin's Avatar
  • Offline
  • Moderator
  • Moderator
  • Deeds not Words
  • Posts: 7638
  • Karma: 33
  • Thank you received: 425
Please provide us with the repository backup and we will have a look.

We do have integrated version control it is there for you so you can avoid issues like this.
Mike

Please Log in or Create an account to join the conversation.

Large Transformation - All Settings Lost? 11 months 3 weeks ago #18733

I appreciate the comment on version control, however, I thought I was saving it each time I pressed save inside each component. Do you have a FAQ on the Version Control?

Anyway, where should I send the repository backup? Should I attach here? I would rather it not be public.

Thank you again.

Please Log in or Create an account to join the conversation.

Large Transformation - All Settings Lost? 11 months 3 weeks ago #18734

On another note, if needed, I am completely willing to pay for the recovery service. I appreciate anything that can be done. Unfortunately, this is a mission critical transformation.

Please Log in or Create an account to join the conversation.

Large Transformation - All Settings Lost? 11 months 3 weeks ago #18735

We are really sorry but we can no assist you this time.
You can try asking IT to restore your computer from backup (or a database is you are using SQL server as a repository)

I can only recommend making regular backups of the repository and using version control.

Here is version control video tutorial
www.etl-tools.com/tutorials/18-version-control.html

And some general "Problem Prevention suggestions"
www.etl-tools.com/tutorials/24-avoiding-...ct-is-completed.html

Please Log in or Create an account to join the conversation.

Large Transformation - All Settings Lost? 11 months 3 weeks ago #18736

Is there any way to just retrieve the transformation mapping information? There were hundreds of fields and lookup tables. Or even the data in the lookup tables. There was so much done that I just don't have time to bother recovering.

Thank you

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2

We have 408 guests and no members online